%clean
rm -rf %{buildroot}
-%post
-/sbin/chkconfig --add dhcpd
-/sbin/chkconfig --add dhcrelay
-
-%preun
-if [ $1 = 0 ]; then # execute this only if we are NOT doing an upgrade
- service dhcpd stop >/dev/null 2>&1
- service dhcrelay stop >/dev/null 2>&1
- /sbin/chkconfig --del dhcpd
- /sbin/chkconfig --del dhcrelay
-fi
-
-%postun
-if [ "$1" -ge "1" ]; then
- service dhcpd condrestart >/dev/null 2>&1
- service dhcrelay condrestart >/dev/null 2>&1
-fi
-
%files
%defattr(-,root,root)
%doc Changes INSTALL INTERNALS COPYING Docs/manual.html
%dir /etc/l2tpns
-%dir /usr/lib/l2tpns
%config(noreplace) /etc/l2tpns/users
%config(noreplace) /etc/l2tpns/startup-config
%config(noreplace) /etc/l2tpns/ip_pool
-/usr/sbin/l2tpns
+%attr(700,root,root) /usr/sbin/l2tpns
+%attr(755,root,root) /usr/lib/l2tpns
%changelog
* Thu Sep 02 2004 David Parrish <david@dparrish.com> 2.0.2
- Initial SPEC file generation
-