projects
/
l2tpns.git
/ blobdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
|
commitdiff
|
tree
raw
|
inline
| side by side
Add DHCPv6 functionality.
[l2tpns.git]
/
debian
/
rules
diff --git
a/debian/rules
b/debian/rules
index
0580bd7
..
cf9fe8d
100755
(executable)
--- a/
debian/rules
+++ b/
debian/rules
@@
-2,9
+2,6
@@
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- CFLAGS += -g
-endif
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
@@
-16,8
+13,9
@@
configure-stamp:
touch configure-stamp
touch configure-stamp
-build: build-stamp
-
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
build-stamp: configure-stamp
dh_testdir
build-stamp: configure-stamp
dh_testdir
@@
-33,14
+31,14
@@
clean:
rm -f build-stamp configure-stamp
# Add here commands to clean up after the build process.
rm -f build-stamp configure-stamp
# Add here commands to clean up after the build process.
-
-
$(MAKE) clean
+
[ ! -f Makefile ] ||
$(MAKE) clean
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean
install: build
dh_testdir
dh_testroot
- dh_
clean -k
+ dh_
prep
dh_installdirs
$(MAKE) install DESTDIR=$(CURDIR)/debian/l2tpns
dh_installdirs
$(MAKE) install DESTDIR=$(CURDIR)/debian/l2tpns