Add spec file
[l2tpns.git] / l2tpns.spec
1 Summary: A high-speed clustered L2TP LNS
2 Name: l2tpns
3 Version: 2.0.2
4 Release: 1
5 Copyright: GPL
6 Group: System Environment/Daemons
7 Source: http://optusnet.dl.sourceforge.net/sourceforge/l2tpns/l2tpns-%{version}.tar.gz
8 URL: http://sourceforge.net/projects/l2tpns
9 BuildRoot: %{_tmppath}/%{name}-%{version}-root
10 Prereq: /sbin/chkconfig
11 BuildRequires: libcli >= 1.8.1
12 Requires: libcli >= 1.8.1
13
14 %description
15 A L2TP LNS which does not require l2tpd, pppd or any kernel patches. Can support
16 up to 65535 active sessions on a single box. Also supports ISP features like
17 speed throttling, walled garden, usage accounting, and more.
18
19 %prep
20 %setup -q
21
22 %build
23 make
24
25 %install
26 rm -rf %{buildroot}
27 mkdir -p %{buildroot}
28 make install DESTDIR=%{buildroot}
29
30 %clean
31 rm -rf %{buildroot}
32
33 %post
34 /sbin/chkconfig --add dhcpd
35 /sbin/chkconfig --add dhcrelay
36
37 %preun
38 if [ $1 = 0 ]; then # execute this only if we are NOT doing an upgrade
39 service dhcpd stop >/dev/null 2>&1
40 service dhcrelay stop >/dev/null 2>&1
41 /sbin/chkconfig --del dhcpd
42 /sbin/chkconfig --del dhcrelay
43 fi
44
45 %postun
46 if [ "$1" -ge "1" ]; then
47 service dhcpd condrestart >/dev/null 2>&1
48 service dhcrelay condrestart >/dev/null 2>&1
49 fi
50
51 %files
52 %defattr(-,root,root)
53 %doc Changes INSTALL INTERNALS COPYING Docs/manual.html
54 %dir /etc/l2tpns
55 %dir /usr/lib/l2tpns
56 %config(noreplace) /etc/l2tpns/users
57 %config(noreplace) /etc/l2tpns/startup-config
58 %config(noreplace) /etc/l2tpns/ip_pool
59 /usr/sbin/l2tpns
60 /etc/l2tpns/users
61
62 %changelog
63 * Thu Sep 02 2004 David Parrish <david@dparrish.com> 2.0.2
64 - Initial SPEC file generation
65