2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
9 configure: configure-stamp
12 # Add here commands to configure the package.
16 build: build-arch build-indep
17 build-arch: build-stamp
18 build-indep: build-stamp
19 build-stamp: configure-stamp
22 # Add here commands to compile the package.
24 #/usr/bin/docbook-to-man debian/l2tpns.sgml > l2tpns.1
31 rm -f build-stamp configure-stamp
33 # Add here commands to clean up after the build process.
34 [ ! -f Makefile ] || $(MAKE) clean
44 $(MAKE) install DESTDIR=$(CURDIR)/debian/l2tpns
45 install -D -m 644 -o root -g root etc/l2tpns.logrotate \
46 $(CURDIR)/debian/l2tpns/etc/logrotate.d/l2tpns
49 # Build architecture-independent files here.
50 binary-indep: build install
51 # We have nothing to do by default.
53 # Build architecture-dependent files here.
54 binary-arch: build install
58 dh_installdocs Docs/manual.html
67 dh_installchangelogs Changes
79 binary: binary-indep binary-arch
80 .PHONY: build clean binary-indep binary-arch binary install configure