2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
5 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
8 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
12 configure: configure-stamp
15 # Add here commands to configure the package.
21 build-stamp: configure-stamp
24 # Add here commands to compile the package.
26 #/usr/bin/docbook-to-man debian/l2tpns.sgml > l2tpns.1
33 rm -f build-stamp configure-stamp
35 # Add here commands to clean up after the build process.
46 $(MAKE) install DESTDIR=$(CURDIR)/debian/l2tpns
47 install -D -m 644 -o root -g root etc/l2tpns.logrotate \
48 $(CURDIR)/debian/l2tpns/etc/logrotate.d/l2tpns
51 # Build architecture-independent files here.
52 binary-indep: build install
53 # We have nothing to do by default.
55 # Build architecture-dependent files here.
56 binary-arch: build install
60 dh_installdocs Docs/manual.html
69 dh_installchangelogs Changes
81 binary: binary-indep binary-arch
82 .PHONY: build clean binary-indep binary-arch binary install configure