* Enabled hardened build flags, thanks Moritz Muehlenhoff (closes: #657846)
[l2tpns.git] / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
6         INSTALL_PROGRAM += -s
7 endif
8
9 configure: configure-stamp
10 configure-stamp:
11         dh_testdir
12         # Add here commands to configure the package.
13
14         touch configure-stamp
15
16 build: build-arch build-indep
17 build-arch: build-stamp
18 build-indep: build-stamp
19 build-stamp: configure-stamp 
20         dh_testdir
21
22         # Add here commands to compile the package.
23         $(MAKE)
24         #/usr/bin/docbook-to-man debian/l2tpns.sgml > l2tpns.1
25
26         touch build-stamp
27
28 clean:
29         dh_testdir
30         dh_testroot
31         rm -f build-stamp configure-stamp
32
33         # Add here commands to clean up after the build process.
34         [ ! -f Makefile ] || $(MAKE) clean
35
36         dh_clean
37
38 install: build
39         dh_testdir
40         dh_testroot
41         dh_prep
42         dh_installdirs
43
44         $(MAKE) install DESTDIR=$(CURDIR)/debian/l2tpns
45         install -D -m 644 -o root -g root etc/l2tpns.logrotate \
46                 $(CURDIR)/debian/l2tpns/etc/logrotate.d/l2tpns
47
48
49 # Build architecture-independent files here.
50 binary-indep: build install
51 # We have nothing to do by default.
52
53 # Build architecture-dependent files here.
54 binary-arch: build install
55         dh_testdir
56         dh_testroot
57 #       dh_installdebconf       
58         dh_installdocs Docs/manual.html
59         dh_installexamples
60         dh_installmenu
61 #       dh_installlogrotate
62 #       dh_installpam
63         dh_installinit
64         dh_installcron
65         dh_installman
66         dh_installinfo
67         dh_installchangelogs Changes
68         dh_link
69         dh_strip
70         dh_compress
71         dh_fixperms
72         dh_installdeb
73 #       dh_perl
74         dh_shlibdeps
75         dh_gencontrol
76         dh_md5sums
77         dh_builddeb
78
79 binary: binary-indep binary-arch
80 .PHONY: build clean binary-indep binary-arch binary install configure